Вышел jQuery 2.0

Вышел jQuery 2.0


Да, да! Всё верно! Буквально несколько часов назад состоялся релиз новой версии одной из самых любимых библиотек - jQuery 2.0.

Как и было обещано, из данной версии выкинули код, отвечающий за поддержку IE 6, 7, 8. Благодаря этому, библиотека стала намного легче и быстрее. Однако беспокоится об этом сильно не стоит, т.к. развитие и поддержка ветки 1.x будет продолжаться ещё несколько лет. Это значит, что мы ещё долго сможем пользоваться актуальной версией 1.9, и готовящейся к релизу 1.10.

Основные изменения jQuery 2.0
Устранение поддержки IE 6/7/8 – это также может касаться и IE 9/10, если в них активирована функция «Представление совместимости».
Уменьшение размера библиотеки – размер библиотеки сократился на 12%.
Появилась возможность настройки библиотеки под себя – теперь у нас появилась возможность выбирать, какие из 12 модулей библиотеки нам нужны (ajax, ajax/xhr, ajax/script, ajax/jsonp, css, deprecated, dimensions, effects, event-alias, offset, wrap, sizzle), чтобы ещё больше уменьшить размер файла.
Схожесть с API версии 1.9 – jQuery 2.0 API совместим с версией 1.9. Это означает, что все изменения версии 1.9 плавно перешли и в новую версию. Если вы ещё не перешли на jQuery 1.9, то воспользуйтесь плагином миграции.

Где скачать библиотеку
Новую версию библиотеки можно скачать с официального jQuery CDN:
http://code.jquery.com/jquery-2.0.0.min.js (сжатая версия)
http://code.jquery.com/jquery-2.0.0.js (для тестирования)

Вскоре данные файлы будут доступны на CDN от Google и Microsoft. Для гарантии функционала, базирующегося на jQuery, указывайте конкретную версию библиотеки, которую хотите использовать.

Если вы будете обновляться с версии 1.9, то разработчики рекомендуют также подключить специальный плагин миграции. Его использовать очень легко. Прикрепляем файл в документе и открываем браузерную консоль для того, чтобы увидеть сообщения.
<script src="http://code.jquery.com/jquery-2.0.0.js"></script>
<script src="http://code.jquery.com/jquery-migrate-1.1.1.js"></script>

Как использовать новую версию
jQuery 2.0 направлен на разработку под современные технологии. jQuery 1.x будет продолжать развиваться ещё пару лет, поддерживая старые браузеры. Если же у вас есть необходимость подключать обе библиотеки, в зависимости от функционала, то в помощь вам специальные проверки:
<!--[if lt IE 9]>
    <script src="jquery-1.9.1.js"></script>
    <![endif]-->
    <!--[if gte IE 9]><!-->
	<script src="jquery-2.0.0.js"></script>
<!--<![endif]-->

С выходом новой версии, расширилась среда применения jQuery:
Плагины Google Chrome
Приложения и расширения для Mozilla
Приложения Firefox OS
Приложения Chrome OS
Приложения Windows 8
Приложения Blackberry 10
Приложения PhoneGap/Cordova
Класс Apple UIWebView
Microsoft WebBrowser
Расширение для Node.js

Добавить комментарий

Нам важно знать ваше мнение. Оставьте свой отзыв или ответ

Комментариев 0

Обновления на форуме