Критические уязвимости, найденные в PhpStorm, требуют немедленного обновления программы

На днях, в JetBrains сообщили о выпуске свежих обновлений безопасности для PhpStorm и других интегрированных средств веб-разработки на основе IntelliJ. Сообщается, что эти обновления исправляют множество критических уязвимостей, которые были допущены в этих системах.

Так, недостаток встроенного веб-сервера интегрированной среды PhpStorm, позволял злоумышленнику провести межсайтовый подлог запроса (CSRF), чтобы заполучить доступ непосредственно к локальной системе файлов, через вредоносную веб-страницу, даже без какого-либо согласия пользователя.

Кроме того, слишком слабые настройки безопасности в совместном использовании ресурсов (CORS), позволяли злоумышленникам использовать вредоносный веб-сайт, чтобы заполучить прямой доступ к внутренним точкам API. Таким образом, они могли видеть некоторые данные, сохраненные в IDE, и собирать информацию об открытом проекте.

PhpStorm является наиболее благоприятной IDE для PHP разработчиков. Он широко используется и среди разработчиков многих CMS, таких как WordPress. Поддержка WordPress даже добавлена в официальной версии программы.

Те обновления, что недавно были опубликованы, исправляют критические уязвимости базовой платформы IntelliJ, а это почти десяток популярных IDE. Установить обновления так же просто, как выбрать опцию «Проверить наличие обновлений» внутри IDE. С другой стороны, клиенты могут сразу загрузить последнюю версию с официального сайта JetBrains, которая уже включает исправления безопасности.

Добавить комментарий

Нам важно знать ваше мнение. Оставьте свой отзыв или ответ

Комментариев 0

Обновления на форуме